aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2014-08-20 11:14:38 -0400
committerJeff Morriss <jeff.morriss.ws@gmail.com>2014-08-20 19:11:42 +0000
commit61b01c37a9f9839a2ad004796e26d74eb8fdc0d1 (patch)
treee0f64fb29d5a570d7f598e3ef92e9ff3073b2fba /configure.ac
parent3adaf99050a0310e18673a616dd0eaf68cd159ac (diff)
If the user explicitly requested gnutls or libgcrypt generate an error if they
are not found. Accurately describe the default behavior: Wireshark will use the libraries if they are available. May help avoid problems like that described in: https://ask.wireshark.org/questions/35600/not-able-to-configure-wireshark-with-gnutls Change-Id: I5f0b2ce87cb7c6b337de93609f13d8027e662263 Reviewed-on: https://code.wireshark.org/review/3750 Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 18 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 543feb430f..044728202e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -478,10 +478,12 @@ AC_ARG_WITH([gtk3],
# version 4.2.2, the switched to LGPLv3+ / GPLv2+ in version 6.0.0.
tls_message="no"
+want_gnutls="if_available"
AC_ARG_WITH([gnutls],
AC_HELP_STRING( [--with-gnutls=@<:@yes/no@:>@],
- [use GnuTLS library @<:@default=yes@:>@]),
- with_gnutls="$withval", with_gnutls="yes")
+ [use GnuTLS library @<:@default=yes, if available@:>@]),
+ [ with_gnutls="$withval"; want_gnutls="yes" ], with_gnutls="yes")
+
if test "x$with_gnutls" = "xyes"; then
have_license_compatible_gnutls="no"
PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 3.1.10 ],
@@ -501,15 +503,22 @@ if test "x$with_gnutls" = "xyes"; then
else
echo "GnuTLS with compatible license not found, disabling SSL decryption"
tls_message="no"
+
+ # Error out if the user explicitly requested gnutls
+ if test "x$want_gnutls" = "xyes"; then
+ AC_MSG_ERROR([GnuTLS crypto library was requested, but is not available])
+ fi
fi
fi
# libgrypt
gcrypt_message="no"
+want_gcrypt="if_available"
AC_ARG_WITH([gcrypt],
AC_HELP_STRING( [--with-gcrypt=@<:@yes/no@:>@],
- [use gcrypt library @<:@default=yes@:>@]),
- with_gcrypt="$withval", with_gcrypt="yes")
+ [use gcrypt library @<:@default=yes, if available@:>@]),
+ [ with_gcrypt="$withval"; want_gcrypt="yes" ], with_gcrypt="yes")
+
if test "x$with_gcrypt" = "xyes"; then
AM_PATH_LIBGCRYPT(1.1.92,
[
@@ -524,6 +533,11 @@ if test "x$with_gcrypt" = "xyes"; then
echo "libgcrypt not found, disabling ipsec decryption"
gcrypt_message="no"
fi
+
+ # Error out if the user explicitly requested gcrypt
+ if test "x$want_gcrypt" = "xyes"; then
+ AC_MSG_ERROR([libgcrypt library was requested, but is not available])
+ fi
]
)
fi