aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2012-09-18 21:42:13 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2012-09-18 21:42:13 +0000
commit5ee932193f8d420cb1839347769841e82f3d8185 (patch)
tree6d62fcc8d4d29869405fa838d142664c4a0d5728 /configure.ac
parentb6e0cc28a56a0547c13d4547328bf827d8a66895 (diff)
*NIX (autofoo and cmake) part of the fix for
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=6134 : Make VERSION_MAJOR, VERSION_MINOR, and VERSION_MICRO available in config.h so (e.g.) dissector writers can #if around them as necessary to make a piece of code compile with different versions of Wireshark. (Hopefully VERSION_MICRO is not important in this respect!) Windows also defines VERSION_EXTRA which can be used to help identify custom builds; this is not done for these build methods (yet?). svn path=/trunk/; revision=44986
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 978c376bf5..fe9ab80566 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,12 @@
#
AC_PREREQ(2.60)
-AC_INIT(wireshark, 1.9.0, http://bugs.wireshark.org/, , http://www.wireshark.org/)
+m4_define(version_major, 1)
+m4_define(version_minor, 9)
+m4_define(version_micro, 0)
+# XXX version_extra ?
+
+AC_INIT(wireshark, [version_major.version_minor.version_micro], http://bugs.wireshark.org/, , http://www.wireshark.org/)
dnl Check for CPU / vendor / OS
dnl The user is encouraged to use either `AC_CANONICAL_BUILD', or
@@ -26,6 +31,11 @@ AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE([1.9 tar-ustar dist-bzip2 no-dist-gzip])
+# Make Wireshark's version available in config.h
+AC_DEFINE(VERSION_MAJOR, version_major, [Wireshark's major version])
+AC_DEFINE(VERSION_MINOR, version_minor, [Wireshark's minor version])
+AC_DEFINE(VERSION_MICRO, version_micro, [Wireshark's micro version])
+
AM_DISABLE_STATIC
dnl Checks for programs.