aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2016-02-14 17:00:38 -0800
committerGuy Harris <guy@alum.mit.edu>2016-02-15 08:31:06 +0000
commit58d00bad1a2c4298bd58013e4808899feb657422 (patch)
treec609d6f4b56c9f99432f4da736797af94161952c /configure.ac
parent21ab9b2cbefeb73cdc605a90e8980240452567c0 (diff)
Build the extcap programs in the extcap directory.
That lets the version of Wireshark built with autotools find the extcap programs. Don't install the extcap programs under ${datadir} - that puts it under a share directory, and share directories are for platform-independent files, which executable images aren't (they're instruction-set dependent, hence platform-dependent). Change-Id: I992eeb984bdbe6b3476777f7114628c83df6080f Reviewed-on: https://code.wireshark.org/review/13943 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 65d05fc7d6..ceb2378bf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3059,8 +3059,8 @@ dnl
dnl check whether extcap programs should be enabled and, if they should be,
dnl check for extcap directory - stolen from Amanda's configure.ac
dnl
-dnl we don't wish to expand ${datadir} yet
-extcapdir="\${datadir}/wireshark/extcap"
+dnl we don't wish to expand ${libdir} yet
+extcapdir="\${libdir}/wireshark/extcap"
AC_ARG_WITH(extcap,
AC_HELP_STRING( [--with-extcap@<:@=DIR@:>@],
[use extcap for external capture sources (installed in DIR, if supplied) @<:@default=yes, if possible@:>@]),
@@ -3288,6 +3288,7 @@ AC_OUTPUT(
epan/nghttp2/Makefile
epan/wmem/Makefile
epan/wslua/Makefile
+ extcap/Makefile
codecs/Makefile
ui/Makefile
ui/doxygen.cfg
@@ -3324,6 +3325,7 @@ AC_OUTPUT(
plugins/wimax/Makefile
plugins/wimaxasncp/Makefile
plugins/wimaxmacphy/Makefile
+ randpkt_core/Makefile
tools/Makefile
tools/lemon/Makefile
wiretap/Makefile