aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Fisher <stephenfisher@centurylink.net>2014-11-05 09:43:00 -0700
committerStephen Fisher <stephenfisher@centurylink.net>2014-11-05 19:24:30 +0000
commit547323b0ba3650a96e59c0b0d76ad2a3783db07d (patch)
tree7d992e374620d5a639bc2f5abee7f1772f84daa3 /configure.ac
parentd2c06006093d0fab30a34490b362f6f85111b0a7 (diff)
Allow the environment variable RCC to set before running configure to
allow for unusual paths for Qt's rcc program (FreeBSD ports puts it in /usr/local/lib/qt5/bin). This matches the existing functionality of the MOC and UIC variables/programs. Change-Id: I885d61bce54d9e893e0c2fc496a9ff767a096ae6 Reviewed-on: https://code.wireshark.org/review/5139 Petri-Dish: Stephen Fisher <stephenfisher@centurylink.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Stephen Fisher <stephenfisher@centurylink.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2e7715113b..cb6a126c2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1715,6 +1715,32 @@ then
fi
fi
AC_SUBST(MOC)
+AC_PATH_PROG(RCC, rcc)
+if test "x$RCC" = x
+then
+ AC_PATH_PROG(RCC, rcc)
+ if test "x$RCC" = x
+ then
+ if test "x$with_qt" = "xyes"; then
+ #
+ # If you want to build with Qt, you'd better
+ # have moc.
+ #
+ AC_MSG_ERROR(I couldn't find rcc; make sure it's installed and in your path)
+ else
+ #
+ # We shouldn't fail here, as the user's not
+ # building with Qt, and we shouldn't force them
+ # to have Qt installed if they're not doing so.
+ # "make dist" will fail if they do that, but
+ # we don't know whether they'll be doing that,
+ # so this is the best we can do.
+ #
+ RCC=rcc
+ fi
+ fi
+fi
+AC_SUBST(RCC)
# Error out if a glib header other than a "top level" header
# (glib.h, glib-object.h, gio.h) or certain other headers( e.g.,gmodule.h)