aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-06-16 01:49:44 -0700
committerGuy Harris <guy@alum.mit.edu>2017-06-16 08:50:22 +0000
commit5039d0e57635589208e1d969a57250746e422e06 (patch)
tree455ae6bfd28a26c33ee4b8cbff8bbb1534380811 /configure.ac
parent63b91ad3119c64eb8fdaa67303fe37d71a01a1b0 (diff)
Change some names to reflect Apple's new UNIX-for-Macs name.
{OS_X,os_x} -> {MACOS,macos}. Change-Id: Icebea6ab566c65996ee97bacb88fac7e84ec32de Reviewed-on: https://code.wireshark.org/review/22161 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a5048daa4f..4da9b93646 100644
--- a/configure.ac
+++ b/configure.ac
@@ -517,7 +517,7 @@ AC_SUBST(HAVE_OSX_PACKAGING)
# don't look for Darwin).
#
AC_CHECK_PROG(have_sw_vers, sw_vers, "yes", "no")
-AM_CONDITIONAL(NOT_OS_X, test "x$have_sw_vers" = "xno")
+AM_CONDITIONAL(NOT_MACOS, test "x$have_sw_vers" = "xno")
# Shellcheck
AC_CHECK_PROG(HAVE_SHELLCHECK, shellcheck, "yes", "no")
@@ -1130,11 +1130,11 @@ AC_SUBST(LDFLAGS_SHAREDLIB)
# get version information from plists and thus need Core Foundation
# to process those plists.
#
-have_os_x_frameworks=no
+have_macos_frameworks=no
case "$host_os" in
darwin*)
- have_os_x_frameworks=yes
- AC_DEFINE(HAVE_OS_X_FRAMEWORKS, 1, [Define to 1 if you have macOS frameworks])
+ have_macos_frameworks=yes
+ AC_DEFINE(HAVE_MACOS_FRAMEWORKS, 1, [Define to 1 if you have macOS frameworks])
APPLICATIONSERVICES_FRAMEWORKS="-framework ApplicationServices"
SYSTEMCONFIGURATION_FRAMEWORKS="-framework SystemConfiguration"
COREFOUNDATION_FRAMEWORKS="-framework CoreFoundation"
@@ -1157,7 +1157,7 @@ esac
AC_SUBST(APPLICATIONSERVICES_FRAMEWORKS)
AC_SUBST(SYSTEMCONFIGURATION_FRAMEWORKS)
AC_SUBST(COREFOUNDATION_FRAMEWORKS)
-AM_CONDITIONAL(HAVE_OS_X_FRAMEWORKS, [test "x$have_os_x_frameworks" = "xyes"])
+AM_CONDITIONAL(HAVE_MACOS_FRAMEWORKS, [test "x$have_macos_frameworks" = "xyes"])
#
# If we're running Solaris, and LD_LIBRARY_PATH is defined, add it as a