aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-07-12 19:12:05 -0700
committerGuy Harris <guy@alum.mit.edu>2015-07-13 02:12:33 +0000
commit494457d3b55630595909d4db883e93f2d3f57986 (patch)
tree2a6445a494dddb0a4830a0cd794d9e1295ded7a3 /configure.ac
parente92086849af8e8611ec2e789aa33a4734ff4208b (diff)
Make OS X .app bundling work with Qt 5.5.
macdeployqt doesn't actually seem to deploy any of Qt into the app bundle, probably because we're using it in a fashion they didn't intend (i.e., not doing everything with *their* build tools), so we just extend our dependency-binding stuff to handle the Qt libraries, and copy over the Qt plugins ourselves. We also add the rpaths to the executables and libraries as part of the app bundle building process; I thought it'd fix macdeployqt's problem, but it didn't, however, it's probably cleaner to do it there anyway. Change-Id: I134c2b1a32e168e82de67f0b674d17167481d69a Reviewed-on: https://code.wireshark.org/review/9612 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 2 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 82b12d2084..86558eeaba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1338,16 +1338,8 @@ darwin*)
# with a static version installed in /usr/local/lib rather than
# the system version in /usr/lib).
#
- # Also add -Wl,-rpath,@executable_path/../lib,
- # -Wl,-rpath,@executable_path/../Frameworks, and
- # -Wl,-rpath,/usr/local/lib, so that, if we build an app
- # bundle, we can tweak all the executable images, shared
- # libraries, and plugins in the bundle to look for non-system
- # libraries in the rpath, rather than having a script tweak
- # DYLD_LIBRARY_PATH.
- #
- LDFLAGS="-Wl,-headerpad_max_install_names -Wl,-search_paths_first -Wl,-rpath,@executable_path/../lib -Wl,-rpath,@executable_path/../Frameworks -Wl,-rpath,/usr/local/lib $LDFLAGS"
- AC_MSG_RESULT([Apple linker - added -Wl,-single_module to shared library linker flags and -Wl,-headerpad_max_install_names -Wl,-search_paths_first and rpaths to all linker flags])
+ LDFLAGS="-Wl,-headerpad_max_install_names -Wl,-search_paths_first $LDFLAGS"
+ AC_MSG_RESULT([Apple linker - added -Wl,-single_module to shared library linker flags and -Wl,-headerpad_max_install_names -Wl,-search_paths_first and -Wl,-headerpad_max_install_names to all linker flags])
;;
cygwin*)
#