aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-02-21 17:10:03 +0000
committerAnders Broman <a.broman58@gmail.com>2016-02-25 04:50:59 +0000
commit394eaa1c20a43d75e59e14bc1d3e968451f880e4 (patch)
tree3876a18b6e48febeb9d60170e28a13bedf22e2c7 /configure.ac
parent03dfd9cead43930e481fad614ac83e760cee98ea (diff)
Add GResource message to configure script
Use more descriptive naming while at it. Change-Id: Ic89562cb9fa2cd5e315992f12ad9e46f2361da0b Reviewed-on: https://code.wireshark.org/review/14057 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 0b24b2481d..719ae06cef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1591,13 +1591,6 @@ GLIB_CFLAGS="$GLIB_CONFIG $GLIB_CFLAGS"
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
-# Check for GResource support
-PKG_CHECK_EXISTS([gio-2.0 >= 2.32 gdk-pixbuf-2.0 >= 2.26], [have_gresource=yes], [have_gresource=no])
-AM_CONDITIONAL(HAVE_GRESOURCE, test "x$have_gresource" = "xyes")
-if test "x$have_gresource" = "xyes"; then
- AC_DEFINE(HAVE_GRESOURCE, 1, [Defined if GLib GResource is supported])
-fi
-
GTK2_MIN_VERSION=2.12.0
AC_SUBST(GTK2_MIN_VERSION)
GTK3_MIN_VERSION=3.0.0
@@ -1831,6 +1824,20 @@ AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
AC_SUBST(GUI_CONFIGURE_FLAGS)
+# Check for GTK GUI support for GResource pixbufs
+have_gresource_pixbuf=no
+if test "x$have_gtk" = "xyes"; then
+ AC_MSG_CHECKING(whether GDK-Pixbuf can load data using GResource)
+ PKG_CHECK_EXISTS([gio-2.0 >= 2.32 gdk-pixbuf-2.0 >= 2.26],
+ [
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_GDK_GRESOURCE, 1, [Defined if GResource is supported])
+ have_gresource_pixbuf=yes
+ ],
+ [AC_MSG_RESULT(no)])
+fi
+AM_CONDITIONAL(HAVE_GRESOURCE_PIXBUF, test "x$have_gresource_pixbuf" = "xyes")
+
if test "$have_gtk" = "yes" -a "$have_qt" = "yes" ; then
# We have both GTK and Qt and thus will be building both wireshark
# and wireshark-gtk.
@@ -3496,4 +3503,4 @@ echo " Use libssh library : $libssh_message"
echo " Have ssh_userauth_agent : $ssh_userauth_agent_message"
echo " Use nl library : $libnl_message"
echo " Use SBC codec library : $have_sbc"
-#echo " Use GResource : $have_gresource"
+#echo " Use GDK-Pixbuf with GResource: $have_gresource_pixbuf"