aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-11-22 09:45:03 +0000
committerJoão Valverde <j@v6e.pt>2017-11-22 11:44:31 +0000
commit871f75ce85b7c3d0c58e05e90d34791042a8d5b8 (patch)
treed6a5e6b1ff0959316152438237799a3c20e1a083 /configure.ac
parent2f2c2b06e2f43c2a18bf1033253ee07c4b2b427e (diff)
make-dissectors: Remove dependency on GNU Make >= 4.0
The $(file ...) function is only available since version 4.0. Until something breaks or someone complains use the shell to write dissectors.c.in. Change-Id: Icfe260004ca04d825c370bb642fcdc4b4be8516f Reviewed-on: https://code.wireshark.org/review/24532 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 2 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 4b4497d2de..3ddf1e11d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,14 +138,9 @@ AC_PROG_MKDIR_P
#
# Check for GNU Make
#
-have_gnu_make=no
-AX_CHECK_GNU_MAKE([have_gnu_make=maybe])
-if test "x$have_gnu_make" = xmaybe; then
- AX_COMPARE_VERSION([$ax_check_gnu_make_version], [ge], [4.0],
- [have_gnu_make=yes])
-fi
+AX_CHECK_GNU_MAKE([have_gnu_make=yes])
if test "x$have_gnu_make" != xyes; then
- AC_MSG_WARN([GNU Make >= 4.0 not found; building Wireshark without it will probably fail])
+ AC_MSG_WARN([GNU Make not found; building Wireshark without it will probably fail])
fi
AC_PATH_PROG(PERL, perl)