aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-11-01 09:23:22 +0000
committerJoão Valverde <j@v6e.pt>2017-11-05 10:39:38 +0000
commit62f705e8445336e73a81e1df10987e24529bf418 (patch)
tree7f1207602130d4e20bad5c676d137cf8ceac2091 /configure.ac
parent711f69c807a5566060bea94ac7042b43bf3cbeab (diff)
autotools: Try to be clearer about --with-ssl and remove cruft
Change-Id: Iaf8c8a83ead1d6671bb9cadb6add56481ed98aaa Reviewed-on: https://code.wireshark.org/review/24242 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 9 insertions, 40 deletions
diff --git a/configure.ac b/configure.ac
index 3c5c1e0dff..3b3475b508 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2134,39 +2134,6 @@ linux*)
;;
esac
-dnl SSL Check
-SSL_LIBS=''
-AC_MSG_CHECKING(whether to use SSL library)
-
-AC_ARG_WITH(ssl,
- AC_HELP_STRING( [--with-ssl@<:@=DIR@:>@],
- [use SSL crypto library (located in directory DIR, if supplied) @<:@default=no@:>@]),
-[
-if test "x$withval" = "xno"; then
- want_ssl=no
-elif test "x$withval" = "xyes"; then
- want_ssl=yes
-elif test -d "$withval"; then
- want_ssl=yes
- AC_WIRESHARK_ADD_DASH_L(WS_LDFLAGS, ${withval}/lib)
-fi
-],[
- want_ssl=no
-])
-if test "x$want_ssl" = "xyes"; then
- AC_MSG_RESULT(yes)
- AC_CHECK_LIB(crypto,EVP_md5,
- [
- SSL_LIBS=-lcrypto
- ],
- [
- AC_MSG_ERROR([SSL crypto library was requested, but is not installed for development])
- ])
-else
- AC_MSG_RESULT(no)
-fi
-AC_SUBST(SSL_LIBS)
-
dnl kerberos check
AC_MSG_CHECKING(whether to use Kerberos library)
@@ -2198,6 +2165,15 @@ else
AC_WIRESHARK_KRB5_CHECK
fi
+dnl
+dnl We use GnuTLS for SSL decryption but some builds of Kerberos require
+dnl linking with OpenSSL. We don't want to build with it by default due to
+dnl annoying license incompatibilities between the OpenSSL license and the GPL,
+dnl so we require an explicit option to configure.
+dnl
+AC_ARG_WITH(krb5-crypto-openssl,
+ AC_HELP_STRING( [--with-krb5-crypto-openssl],
+ [Allow linking with OpenSSL for Kerberos crypto backend @<:@default=no@:>@]))
dnl c-ares Check
C_ARES_LIBS=''
@@ -2936,12 +2912,6 @@ else
portaudio_message="no"
fi
-if test "x$want_ssl" = "xno" ; then
- ssl_message="no"
-else
- ssl_message="yes"
-fi
-
if test "x$want_krb5" = "xno" ; then
krb5_message="no"
else
@@ -3044,7 +3014,6 @@ echo " Use kerberos library : $krb5_message"
echo " Use c-ares library : $c_ares_message"
echo " Use SMI MIB library : $libsmi_message"
echo " Use GNU gcrypt library : yes"
-echo " Use SSL crypto library : $ssl_message"
echo " Use GnuTLS library : $tls_message"
echo " Use POSIX capabilities library : $libcap_message"
echo " Use GeoIP library : $geoip_message"