aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2016-10-21 22:19:46 -0700
committerGuy Harris <guy@alum.mit.edu>2016-10-22 05:20:22 +0000
commit528894e72f973c5db5dc76c975620754f7bbe5aa (patch)
treebd4fc32180655bd1f9e935a2b75220c80ac8e3dd /configure.ac
parentd16295bc9b48a526f12237467536bac4220e53da (diff)
On UN*X, st_ctime is the last status change time, not the creation time.
That's the time the file's inode last changed, so size changes, permission changes, etc. affect it. It's *not* the time the file was created; most UN*Xes don't provide that. Newer versions of FreeBSD, NetBSD, OpenBSD, and macOS do, but other UN*Xes don't appear to. On Windows, at least according to Microsoft's documentation, st_ctime *is* the creation time. Hopefully that's not the result of confusion on the part of somebody at Microsoft. Change-Id: I20743703f6ef66e40dff9004dc91bed46af6fad0 Reviewed-on: https://code.wireshark.org/review/18378 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9805e38f44..d03b3cccfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2426,6 +2426,12 @@ AC_STRUCT_TIMEZONE
AC_CHECK_MEMBERS([struct stat.st_flags])
+# We need to know whether "struct stat" has an "st_birthtime" member
+# or an "__st_birthtime" member for the file set dialog.
+
+AC_CHECK_MEMBERS([struct stat.st_birthtime])
+AC_CHECK_MEMBERS([struct stat.__st_birthtime])
+
# We need to know whether "struct sockaddr" has an "sa_len" member
# for get_interface_list().