aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn A. Thacker <johnthacker@gmail.com>2016-06-13 16:36:07 -0400
committerMichael Mann <mmann78@netscape.net>2016-06-13 23:46:59 +0000
commit4e135882d9f7809fb160119547f3a4eac231146e (patch)
tree95b43560b6d028afc5d0ccf1cd7010577d13919e /configure.ac
parent49430824cb5a4b1ceff229f7a21157475b279fe3 (diff)
extcap: Check libssh >= 0.6.0 for sshdump, ciscodump
sshdump and ciscodump require libssh >= 0.6.0. Check for this version and only build them if a sufficient version is present. (The other checks stay; in particular, ssh_userauth_agent doesn't exist on Windows and must be checked separately.) Bug: 12507 Change-Id: Ibe42b0cbb597cd9c4aab51f44d48185940ad954b Reviewed-on: https://code.wireshark.org/review/15882 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Dario Lombardo <lomato@gmail.com> Tested-by: Dario Lombardo <lomato@gmail.com> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7aa50ba2c3..c051caabc4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2527,8 +2527,8 @@ AC_ARG_ENABLE(sshdump,
if test "x$have_extcap" != xyes; then
AC_MSG_RESULT([no, extcap disabled])
enable_sshdump=no
-elif test "x$have_good_libssh" != xyes; then
- AC_MSG_RESULT([no, libssh not available])
+elif test "x$have_libssh_pointsix" != xyes; then
+ AC_MSG_RESULT([no, libssh >= 0.6.0 not available])
enable_sshdump=no
elif test "x$enable_sshdump" = "xyes" ; then
AC_MSG_RESULT(yes)
@@ -2557,8 +2557,8 @@ AC_ARG_ENABLE(ciscodump,
if test "x$have_extcap" != xyes; then
AC_MSG_RESULT([no, extcap disabled])
enable_ciscodump=no
-elif test "x$have_good_libssh" != xyes; then
- AC_MSG_RESULT([no, libssh not available])
+elif test "x$have_libssh_pointsix" != xyes; then
+ AC_MSG_RESULT([no, libssh >= 0.6.0 not available])
enable_ciscodump=no
elif test "x$enable_ciscodump" = "xyes" ; then
AC_MSG_RESULT(yes)