aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-11-21 04:09:09 +0000
committerJoão Valverde <j@v6e.pt>2017-11-21 10:35:18 +0000
commit4a125fb183a5944693854edb8cf07a7bd57b90df (patch)
tree1af7575d273225fd6b2d5aeed19a5887f671f77b /configure.ac
parent1470aeef4cd4b1660d68c2907dc7b58f9d16df58 (diff)
configure: Check for minimum required GNU Make version
Change-Id: Ifb76a8426f3233e277a129e1d4e4a5ac0c832503 Reviewed-on: https://code.wireshark.org/review/24518 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c1f84ea155..8abddafe02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,19 @@ AC_PROG_SED
AC_PROG_LN_S
AC_PROG_MKDIR_P
+#
+# Check for GNU Make
+#
+have_gnu_make=no
+AX_CHECK_GNU_MAKE([have_gnu_make=maybe])
+if test "x$have_gnu_make" = xmaybe; then
+ AX_COMPARE_VERSION([$ax_check_gnu_make_version], [ge], [4.0],
+ [have_gnu_make=yes])
+fi
+if test "x$have_gnu_make" != xyes; then
+ AC_MSG_ERROR([GNU Make version 4.0 or greater is required to build Wireshark])
+fi
+
AC_PATH_PROG(PERL, perl)
# Check for Python.