aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2016-02-10 15:45:45 +0100
committerRoland Knall <rknall@gmail.com>2016-09-16 08:07:30 +0000
commit47650d357e3115e89b854f195b385855c4703a21 (patch)
treecddd7aa4afabed55153e4729664f22fc9005f61f /configure.ac
parent1cd3587b739c5e5aa1b5fd75c8df4ca374f4a6ff (diff)
extcap: add udpdump.
Udpdump is a generic UDP receiver that exports datagram in PCAP format. Change-Id: I52620a92b12530b6f9b5449c43e692663acdfc14 Reviewed-on: https://code.wireshark.org/review/17195 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Roland Knall <rknall@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa041d54f5..42fc22d2c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2613,6 +2613,33 @@ fi
AC_SUBST(randpktdump_bin)
AC_SUBST(randpktdump_man)
+dnl udpdump check
+AC_MSG_CHECKING(whether to build udpdump)
+
+AC_ARG_ENABLE(udpdump,
+ AC_HELP_STRING( [--enable-udpdump],
+ [build udpdump @<:@default=yes@:>@]),
+ [],[enable_udpdump=yes])
+
+if test "x$have_extcap" != xyes; then
+ AC_MSG_RESULT([no, extcap disabled])
+ enable_udpdump=no
+elif test "x$enable_udpdump" = "xyes" ; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+
+if test "x$enable_udpdump" = "xyes" ; then
+ udpdump_bin="udpdump\$(EXEEXT)"
+ udpdump_man="udpdump.1"
+else
+ udpdump_bin=""
+ udpdump_man=""
+fi
+AC_SUBST(udpdump_bin)
+AC_SUBST(udpdump_man)
+
AM_CONDITIONAL(ENABLE_STATIC, test x$enable_static = xyes)
if test x$enable_static = xyes -a x$have_plugins = xyes
then
@@ -2981,6 +3008,7 @@ echo " Build androiddump : $enable_androiddump"
echo " Build sshdump : $enable_sshdump"
echo " Build ciscodump : $enable_ciscodump"
echo " Build randpktdump : $enable_randpktdump"
+echo " Build udpdump : $enable_udpdump"
echo " Build echld : $have_echld"
echo ""
echo " Save files as pcap-ng by default : $enable_pcap_ng_default"