aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Zawadzki <darkjames-ws@darkjames.pl>2017-12-06 21:10:29 +0100
committerGerald Combs <gerald@wireshark.org>2017-12-07 23:26:52 +0000
commit038aa2a616db5ba658bee25dee5e55a716d4984a (patch)
treea32b974aab37a1d9d6548348d68d3f94874269cb /configure.ac
parent8687fca8a821f95075e8c365c7422f157845787b (diff)
Add fuzzshark to cmake/autotools.
Add fuzzshark target to make sure that oss-fuzzshark always build. Change-Id: I802b679c18023daa1475a54bae722b5e90c72a59 Reviewed-on: https://code.wireshark.org/review/24716 Petri-Dish: Jakub Zawadzki <darkjames-ws@darkjames.pl> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ea5de863d..5e5144df26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1781,6 +1781,19 @@ fi
AC_SUBST(tfshark_bin)
AC_SUBST(tfshark_man)
+# Enable/disable fuzzshark
+AC_ARG_ENABLE(fuzzshark,
+ AC_HELP_STRING( [--enable-fuzzshark],
+ [build fuzzshark @<:@default=yes@:>@]),
+ fuzzshark=$enableval,enable_fuzzshark=yes)
+
+if test "x$enable_fuzzshark" = "xyes" ; then
+ fuzzshark_bin="fuzzshark\$(EXEEXT)"
+else
+ fuzzshark_bin=""
+fi
+AC_SUBST(fuzzshark_bin)
+
dnl Use pcap-ng by default
AC_ARG_ENABLE(pcap-ng-default,
@@ -2991,6 +3004,7 @@ echo " Build randpkt : $enable_randpkt"
echo " Build dftest : $enable_dftest"
echo " Build rawshark : $enable_rawshark"
echo " Build sharkd : $enable_sharkd"
+echo " Build fuzzshark : $enable_fuzzshark"
echo " Build androiddump : $enable_androiddump"
echo " Build sshdump : $enable_sshdump"
echo " Build ciscodump : $enable_ciscodump"