aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-09-10 10:28:30 +0000
committerGuy Harris <guy@alum.mit.edu>2013-09-10 10:28:30 +0000
commitd5909d38a1af06eeadae0b78553fcd9f4dbc5a2a (patch)
tree5ffe28c717a679e5e9352f7cc9adf7d1284e87aa /configure.ac
parent860856b4248488513532f065b98203f4556e20ec (diff)
Use -m32, instead, as per Michael Tuexen's suggestion.
svn path=/trunk/; revision=51923
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 3 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 81a499efe7..90e7c5bde2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -434,18 +434,9 @@ then
# functions not to work with 64-bit userland
# code, so capturing won't work.
#
- case $host_cpu in
- i*86 | x86_64)
- CFLAGS="-arch i386 $CFLAGS"
- CXXFLAGS="-arch i386 $CXXFLAGS"
- LDFLAGS="-arch i386 $LDFLAGS"
- ;;
- powerpc*)
- CFLAGS="-arch ppc $CFLAGS"
- CXXFLAGS="-arch ppc $CXXFLAGS"
- LDFLAGS="-arch ppc $LDFLAGS"
- ;;
- esac
+ CFLAGS="-m32 $CFLAGS"
+ CXXFLAGS="-m32 $CXXFLAGS"
+ LDFLAGS="-m32 $LDFLAGS"
;;
esac
else