aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-05-10 19:25:38 +0100
committerJoão Valverde <j@v6e.pt>2016-05-16 14:16:41 +0000
commit9f8fc21b62307da7e63884b677af7e7af84cb5c7 (patch)
tree073a02bc6200aea9d94ae8cc874f9a2033285c7a /configure.ac
parentea626b5a9c53357df2e5bc48b0dc1e8f5a8df035 (diff)
autotools: Check for SpeexDSP system library
Change-Id: Ie07f49ec5a563f3b43a2442e05646c6a0b51ca41 Reviewed-on: https://code.wireshark.org/review/15349 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7dffab5dc..15379961e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2403,6 +2403,15 @@ AC_CHECK_FUNCS(sysconf)
AC_CHECK_FUNCS(getifaddrs)
AC_CHECK_FUNC(getexecname)
+#
+# Check for SpeexDSP (http://www.speex.org)
+#
+AS_IF([test "x$have_qt_multimedia_lib" = xyes],
+ [PKG_CHECK_MODULES(SPEEXDSP, speexdsp, [have_speexdsp=yes], [have_speexdsp=no])])
+AS_IF([test "x$have_speexdsp" = xyes],
+ [AC_DEFINE(HAVE_SPEEXDSP, 1, [Define to 1 if you have SpeexDSP])])
+AM_CONDITIONAL(HAVE_SPEEXDSP, [test "x$have_speexdsp" = "xyes"])
+
# Check Bluetooth SBC codec for RTP Player
# git://git.kernel.org/pub/scm/bluetooth/sbc.git
AC_ARG_WITH([sbc],