aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEvan Huus <eapache@gmail.com>2013-06-25 20:49:16 +0000
committerEvan Huus <eapache@gmail.com>2013-06-25 20:49:16 +0000
commit242a37ea3ec277f41bd21687596eaf8c1bc25630 (patch)
tree294bf0bf2148ba9e9d48c5c15641cb5975b79540 /configure.ac
parent9cb2e270d67ed2beae24313613fb3cc7995c1cc5 (diff)
Look for moc-qt4 before moc and uic-qt4 before uic, because (at least on my
machine, with both qt4 and qt5 development tools installed), moc and uic are the qt5 versions, but the rest of the configuration process grabs qt4 headers and link paths, leading to a lot of weird errors. svn path=/trunk/; revision=50150
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6516c7d371..b914b7ede5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1209,10 +1209,10 @@ fi
# installed; if they're still doing that in current Fedora releases,
# perhaps there will also be XXX-qt5 when they pick up Qt 5.
#
-AC_PATH_PROG(UIC, uic)
+AC_PATH_PROG(UIC, uic-qt4)
if test "x$UIC" = x
then
- AC_PATH_PROG(UIC, uic-qt4)
+ AC_PATH_PROG(UIC, uic)
if test "x$UIC" = x
then
if test "x$with_qt" = "xyes"; then
@@ -1235,10 +1235,10 @@ then
fi
fi
AC_SUBST(UIC)
-AC_PATH_PROG(MOC, moc)
+AC_PATH_PROG(MOC, moc-qt4)
if test "x$MOC" = x
then
- AC_PATH_PROG(MOC, moc-qt4)
+ AC_PATH_PROG(MOC, moc)
if test "x$MOC" = x
then
if test "x$with_qt" = "xyes"; then