aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndersBroman <anders.broman@ericsson.com>2014-06-10 14:47:09 +0200
committerAnders Broman <a.broman58@gmail.com>2014-06-10 14:51:26 +0000
commitfcb019acb8932855d51b0facc45aa3e855fe8524 (patch)
tree7ca38756f1338784d8f184bda956716a40738698 /configure.ac
parent94dcbfd9ac3af4c9d878f4653db4f2a7f8f1158a (diff)
Change HAVE_SSE42 to HAVE_SSE4_2 add $(SIMD_FLAGS)
Add autotools macros to distribution Call AX_EXT to define HAVE_SSE4_2 Change-Id: I9ff085d923dfafb32510cdd14290e74a2aaea302 Reviewed-on: https://code.wireshark.org/review/2110 Tested-by: Anders Broman <a.broman58@gmail.com> Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d17b28f210..e5a806fe0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,12 @@ AC_PROG_CPP
AC_PROG_MKDIR_P
AC_WIRESHARK_CLANG_CHECK
+# Find supported SIMD extensions by requesting cpuid. When an SIMD
+# extension is found, the -m"simdextensionname" is added to SIMD_FLAGS
+# (only if compilator support it) (ie : if "sse2" is available "-msse2" is
+# added to SIMD_FLAGS)
+AX_EXT
+
dnl Work around libtool bug (fixed in the version 1.5a?)
AC_DEFUN([AC_PROVIDE_AC_LIBTOOL_DLOPEN], )
AC_LIBTOOL_DLOPEN