aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexis La Goutte <alexis.lagoutte@gmail.com>2013-11-19 12:27:09 +0000
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2013-11-19 12:27:09 +0000
commitd28d1a8240ec440778f4a5c3d2f9f7ad34d9530c (patch)
tree458efecbd3a4c0bafc973018c633eabfe9f8df97 /configure.ac
parent11b3ae86537487e296276119f0880952faf9af2b (diff)
Fix compilation with Clang (Remove limitation to -fPIE to only C)
/usr/include/qt5/QtCore/qglobal.h:1079:4: error: "You must build your code with position independent code if Qt was built with -reduce-relocations. " "Compile your code with -fPIC or -fPIE." svn path=/trunk/; revision=53432
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9f00ed8c17..06367778ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -927,7 +927,7 @@ AC_WIRESHARK_LDFLAGS_CHECK([-Wl,--as-needed])
# in the address space to make attacks more difficult.
#
CFLAGS_before_pie=$CFLAGS
-AC_WIRESHARK_COMPILER_FLAGS_CHECK(-fPIE, C)
+AC_WIRESHARK_COMPILER_FLAGS_CHECK(-fPIE)
if test "x$CLFAGS" != "x$CFLAGS_before_pie"
then
# Restore CFLAGS