aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-12-27 11:08:41 +0000
committerGuy Harris <guy@alum.mit.edu>2013-12-27 11:08:41 +0000
commitcc74708a796d38f11993df8061d833dfe052489e (patch)
tree5eedbeb6212aa5f62fab00b2f67421312a304a4e /configure.ac
parentd0915cabb3001ba3d7e796dd489e309e9aa2a4ce (diff)
Fix some typoes, quote $CFLAGS and $LDFLAGS when using them in
assignments (not sure that's necessary, but...). svn path=/trunk/; revision=54474
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 2505ac1a27..5808cded2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -917,9 +917,9 @@ esac
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-fexcess-precision=fast)
-CFLAGS_before_fvhidden=$CFLAGS
+CFLAGS_before_fvhidden="$CFLAGS"
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-fvisibility=hidden)
-if test "x$CLFAGS" = "x$CFLAGS_before_fvhidden"
+if test "x$CFLAGS" = "x$CFLAGS_before_fvhidden"
then
# TODO add other ways of hiding symbols
AC_MSG_WARN(Compiler will export all symbols from shared libraries)
@@ -938,14 +938,14 @@ AC_WIRESHARK_LDFLAGS_CHECK([-Wl,--as-needed])
# privileges, and using PIE means the OS can run it at random locations
# in the address space to make attacks more difficult.
#
-CFLAGS_before_pie=$CFLAGS
+CFLAGS_before_pie="$CFLAGS"
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-fPIE)
-if test "x$CLFAGS" != "x$CFLAGS_before_pie"
+if test "x$CFLAGS" != "x$CFLAGS_before_pie"
then
# Restore CFLAGS
- CFLAGS=$CFLAGS_before_pie
+ CFLAGS="$CFLAGS_before_pie"
- LDFLAGS_before_pie=$LDFLAGS
+ LDFLAGS_before_pie="$LDFLAGS"
AC_WIRESHARK_LDFLAGS_CHECK([-fPIE -pie])
if test "x$LDFLAGS" != "x$LDFLAGS_before_pie"
then
@@ -954,7 +954,7 @@ then
PIE_LDFLAGS="-pie"
# Restore LDFLAGS
- LDFLAGS=$LDFLAGS_before_pie
+ LDFLAGS="$LDFLAGS_before_pie"
fi
fi