aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2015-02-16 22:26:23 +0100
committerJörg Mayer <jmayer@loplof.de>2015-02-16 21:28:04 +0000
commitbe5259d29e063a91911485463e715ba0a9873dd1 (patch)
tree104ed89812eeb48db9af59be4b5a9fb45852fd0d /configure.ac
parenta5f43891aaaa7f7e92f80e3e1ace3e202d785606 (diff)
OK, at least on my system uic is called uic-qt5, same for moc and rcc.
Found while doing an accidental autofoo build instead of cmake build. Change-Id: Ie8ab648561f88e0a28a64c06d4d78652643c91dd Reviewed-on: https://code.wireshark.org/review/7187 Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac114
1 files changed, 63 insertions, 51 deletions
diff --git a/configure.ac b/configure.ac
index 5f095beac0..4b7db7e165 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1743,25 +1743,29 @@ fi
AC_PATH_PROG(UIC, uic)
if test "x$UIC" = x
then
- AC_PATH_PROG(UIC, uic-qt4)
+ AC_PATH_PROG(UIC, uic-qt5)
if test "x$UIC" = x
then
- if test "x$with_qt" = "xyes"; then
- #
- # If you want to build with Qt, you'd better
- # have uic.
- #
- AC_MSG_ERROR(I couldn't find uic or uic-qt4; make sure it's installed and in your path)
- else
- #
- # We shouldn't fail here, as the user's not
- # building with Qt, and we shouldn't force them
- # to have Qt installed if they're not doing so.
- # "make dist" will fail if they do that, but
- # we don't know whether they'll be doing that,
- # so this is the best we can do.
- #
- UIC=uic
+ AC_PATH_PROG(UIC, uic-qt4)
+ if test "x$UIC" = x
+ then
+ if test "x$with_qt" = "xyes"; then
+ #
+ # If you want to build with Qt, you'd better
+ # have uic.
+ #
+ AC_MSG_ERROR(I couldn't find uic or uic-qt5 or uic-qt4; make sure it's installed and in your path)
+ else
+ #
+ # We shouldn't fail here, as the user's not
+ # building with Qt, and we shouldn't force them
+ # to have Qt installed if they're not doing so.
+ # "make dist" will fail if they do that, but
+ # we don't know whether they'll be doing that,
+ # so this is the best we can do.
+ #
+ UIC=uic
+ fi
fi
fi
fi
@@ -1769,25 +1773,29 @@ AC_SUBST(UIC)
AC_PATH_PROG(MOC, moc)
if test "x$MOC" = x
then
- AC_PATH_PROG(MOC, moc-qt4)
+ AC_PATH_PROG(MOC, moc-qt5)
if test "x$MOC" = x
then
- if test "x$with_qt" = "xyes"; then
- #
- # If you want to build with Qt, you'd better
- # have moc.
- #
- AC_MSG_ERROR(I couldn't find moc or moc-qt4; make sure it's installed and in your path)
- else
- #
- # We shouldn't fail here, as the user's not
- # building with Qt, and we shouldn't force them
- # to have Qt installed if they're not doing so.
- # "make dist" will fail if they do that, but
- # we don't know whether they'll be doing that,
- # so this is the best we can do.
- #
- MIC=moc
+ AC_PATH_PROG(MOC, moc-qt4)
+ if test "x$MOC" = x
+ then
+ if test "x$with_qt" = "xyes"; then
+ #
+ # If you want to build with Qt, you'd better
+ # have moc.
+ #
+ AC_MSG_ERROR(I couldn't find moc or moc-qt5 or moc-qt4; make sure it's installed and in your path)
+ else
+ #
+ # We shouldn't fail here, as the user's not
+ # building with Qt, and we shouldn't force them
+ # to have Qt installed if they're not doing so.
+ # "make dist" will fail if they do that, but
+ # we don't know whether they'll be doing that,
+ # so this is the best we can do.
+ #
+ MIC=moc
+ fi
fi
fi
fi
@@ -1795,25 +1803,29 @@ AC_SUBST(MOC)
AC_PATH_PROG(RCC, rcc)
if test "x$RCC" = x
then
- AC_PATH_PROG(RCC, rcc)
+ AC_PATH_PROG(RCC, rcc-qt5)
if test "x$RCC" = x
then
- if test "x$with_qt" = "xyes"; then
- #
- # If you want to build with Qt, you'd better
- # have moc.
- #
- AC_MSG_ERROR(I couldn't find rcc; make sure it's installed and in your path)
- else
- #
- # We shouldn't fail here, as the user's not
- # building with Qt, and we shouldn't force them
- # to have Qt installed if they're not doing so.
- # "make dist" will fail if they do that, but
- # we don't know whether they'll be doing that,
- # so this is the best we can do.
- #
- RCC=rcc
+ AC_PATH_PROG(RCC, rcc)
+ if test "x$RCC" = x
+ then
+ if test "x$with_qt" = "xyes"; then
+ #
+ # If you want to build with Qt, you'd better
+ # have moc.
+ #
+ AC_MSG_ERROR(I couldn't find rcc or rcc-qt5; make sure it's installed and in your path)
+ else
+ #
+ # We shouldn't fail here, as the user's not
+ # building with Qt, and we shouldn't force them
+ # to have Qt installed if they're not doing so.
+ # "make dist" will fail if they do that, but
+ # we don't know whether they'll be doing that,
+ # so this is the best we can do.
+ #
+ RCC=rcc
+ fi
fi
fi
fi