aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Labedzki <michal.labedzki@tieto.com>2015-02-14 19:10:21 +0100
committerMichal Labedzki <michal.labedzki@tieto.com>2015-04-08 09:57:24 +0000
commitb99cf21c2546bc8260d50f17e60ab614092dac24 (patch)
tree174ffadfa3b220192e64244f9d17fdfb1e0a80bf /configure.ac
parentf3d2cb5881f320386ca8c4af26053121811edbec (diff)
extcap: Add support for Android - androiddump
androiddump is extcap program that can be used with Android devices (need Android SDK in system PATH). Supported is Logcat/Logger logs and Bluetooth interfaces for all Android to this day (Lollipop). Please note that it will work also for FirefoxOS. Interfaces: 1. Logcat Main (binary or text) 2. Logcat System (binary or text) 3. Logcat Events (binary or text) 4. Logcat Radio (binary or text) 5. Logcat Crash (text; Lollipop) 6. Bluetooth Hcidump (<Kitkat) 7. Bluetooth Bluedroid External Parser (Kitkat) 8. Bluetooth BtsnoopNet (Lollipop) Change-Id: I26e4cd1a37a6af805f8b932399b4aa44ee7b5a80 Reviewed-on: https://code.wireshark.org/review/7475 Petri-Dish: Michal Labedzki <michal.labedzki@tieto.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Michal Labedzki <michal.labedzki@tieto.com> Tested-by: Michal Labedzki <michal.labedzki@tieto.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 085b663a52..1abc56ee46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2296,6 +2296,38 @@ fi
AC_SUBST(rawshark_bin)
AC_SUBST(rawshark_man)
+dnl androiddump check
+AC_MSG_CHECKING(whether to build androiddump)
+
+AC_ARG_ENABLE(androiddump,
+ AC_HELP_STRING( [--enable-androiddump],
+ [build androiddump @<:@default=yes@:>@]),
+ androiddump=$enableval,enable_androiddump=yes)
+
+if test "x$enable_androiddump" = "xyes" ; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+
+AC_ARG_ENABLE(androiddump_use_libpcap,
+ AC_HELP_STRING( [--enable-androiddump-use-libpcap],
+ [build androiddump using libpcap @<:@default=no@:>@]),
+ androiddump_use_libpcap=$enableval,enable_androiddump_use_libpcap=no)
+
+if test "x$enable_androiddump_use_libpcap" = "xyes" ; then
+ AC_DEFINE(ANDROIDDUMP_USE_LIBPCAP, 1, [Androiddump will use Libpcap])
+fi
+
+if test "x$enable_androiddump" = "xyes" ; then
+ androiddump_bin="androiddump\$(EXEEXT)"
+ androiddump_man=""
+else
+ androiddump_bin=""
+ androiddump_man=""
+fi
+AC_SUBST(androiddump_bin)
+AC_SUBST(androiddump_man)
# Enable/disable echld
AC_ARG_ENABLE(echld,
@@ -3343,6 +3375,7 @@ echo " Build text2pcap : $enable_text2pcap"
echo " Build randpkt : $enable_randpkt"
echo " Build dftest : $enable_dftest"
echo " Build rawshark : $enable_rawshark"
+echo " Build androiddump : $enable_androiddump"
echo " Build echld : $have_echld"
echo ""
echo " Save files as pcap-ng by default : $enable_pcap_ng_default"