aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-02-14 00:04:36 -0800
committerGuy Harris <guy@alum.mit.edu>2015-02-14 09:10:56 +0000
commita64fc6cf442f7dd566f85696aae17ab2249ba01f (patch)
treed90d34a6a73853df130f87c669d834a6f169abdb /configure.ac
parentf62353755b124472673620491d7709c4d35a6a80 (diff)
Don't check for C89 headers.
1988 called, they want their lack of a C standard back. We don't need to check whether we have stdarg.h, stddef.h, stdlib.h, or string.h, as they're specified by C89 and I don't think there are any platforms we care about that don't have a C89 environment in which we could be built. Change-Id: I447551181284fab7722354b62774625ed8ee94bc Reviewed-on: https://code.wireshark.org/review/7110 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4e866dc073..6e21650455 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2537,7 +2537,7 @@ AC_SUBST(LIBCAP_LIBS)
dnl Checks for header files.
dnl Some of these may not be needed: http://hacks.owlfolio.org/header-survey/
-AC_CHECK_HEADERS(fcntl.h getopt.h grp.h inttypes.h netdb.h pwd.h stdarg.h stddef.h unistd.h)
+AC_CHECK_HEADERS(fcntl.h getopt.h grp.h inttypes.h netdb.h pwd.h unistd.h)
AC_CHECK_HEADERS(sys/ioctl.h sys/param.h sys/socket.h sys/sockio.h sys/stat.h sys/time.h sys/types.h sys/utsname.h sys/wait.h)
AC_CHECK_HEADERS(netinet/in.h)
AC_CHECK_HEADERS(arpa/inet.h arpa/nameser.h)