aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-12-24 18:43:42 +0000
committerGuy Harris <guy@alum.mit.edu>2013-12-24 18:43:42 +0000
commit8713e0457b9ce2993d04d33e9eae715826850269 (patch)
treee0358623622e4d0b290c700739efadb7d2bd23d6 /configure.ac
parent68e7ccc5dc234425ae758f63bdbb8194c5c8d6a6 (diff)
Some warning options are, for reasons not entirely obvious to me, not
supported by some versions of g++ even though the corresponding version of gcc supports them. Other versions of g++, and clang, support them. Check, before adding a -W option for C++, whether the compiler supports it; that check must be done with -Werror, at least with g++, in order to get a non-zero exit status from the compiler. svn path=/trunk/; revision=54447
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8fec259059..2505ac1a27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -750,12 +750,18 @@ fi
AC_SUBST(HAVE_OSX_PACKAGING)
#
-# Some compilers have to be told to fail on unknown warning errors;
+# Some compilers have to be told to fail when passed an unknown -W flag;
# make sure we do that.
#
AC_WIRESHARK_CHECK_UNKNOWN_WARNING_OPTION_ERROR
#
+# Some C++ compilers have to be told to fail when passed a -W flag that
+# they don't think should apply to C++; make sure we do that.
+#
+AC_WIRESHARK_CHECK_NON_CXX_WARNING_OPTION_ERROR
+
+#
# Try to add some additional gcc checks to CFLAGS
#
AC_ARG_ENABLE(extra-gcc-checks,
@@ -801,7 +807,7 @@ AC_ARG_ENABLE(extra-gcc-checks,
#
# All the registration functions block these for now.
#
- AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wmissing-prototypes, C)
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wmissing-prototypes)
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wmissing-declarations)
#
# A bunch of "that might not work on SPARC" code blocks