aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGerald Combs <gerald@zing.org>2015-02-14 13:36:45 -0800
committerGuy Harris <guy@alum.mit.edu>2015-02-14 22:55:00 +0000
commit65763cf6acb14d41ffbf37213268b2f64038e4f9 (patch)
tree14bf27cac8c973af602d27769464167988a3d880 /configure.ac
parent1b43a80c0d19244608b0d01ff483445504d2e563 (diff)
Try to fix diagnostic suppression.
Test the compiler for "-Wpedantic" instead of "-pedantic" since DIAG_OFF and DIAG_ON expect a "-W" flag prefix. Be more strict about the compiler versions that DIAG_OFF and DIAG_ON support. Change-Id: I9304c544912102f1719b79e9250f97b40a324430 Reviewed-on: https://code.wireshark.org/review/7123 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8392611d8f..1896d08008 100644
--- a/configure.ac
+++ b/configure.ac
@@ -867,7 +867,7 @@ AC_ARG_ENABLE(extra-compiler-warnings,
#
# The following are for C and C++
#
- AC_WIRESHARK_COMPILER_FLAGS_CHECK(-pedantic)
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wpedantic)
#
# Various code blocks this one.
#