aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-04-11 21:07:24 -0700
committerGuy Harris <guy@alum.mit.edu>2015-04-12 04:07:53 +0000
commit5f933e85604cc9981954cb821736e0d68d0c4c12 (patch)
treeec19b3ac753063d012d8b4d9e825edac14ff147c /configure.ac
parent6c34e9a8443fe8640016c84657ebb60806d9dffc (diff)
Only add flags to CFLAGS_FOR_BUILD if $CC and $CC_FOR_BUILD are the same.
Otherwise, just because a flag is appropriate for $CC, that doesn't necessarily mean it's appropriate for $CFLAGS_FOR_BUILD. (We don't use CFLAGS_FOR_BUILD for many things, so it's probably not worth making a lot of effort to throw all the warning flags into it if we're cross-compiling; we *do* throw them in for native compilation, which is what most developers use and test with, so that should be sufficient to let the warnings catch problems with the build tools we're building.) Change-Id: Iad9d611b4687e9e154f9871f741f3c8f3b307c88 Reviewed-on: https://code.wireshark.org/review/8026 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1abc56ee46..dc69e7fb1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1284,7 +1284,15 @@ else
# documentation I can find online.
#
CFLAGS="-Ae +O2 $CFLAGS"
- CFLAGS_FOR_BUILD="-Ae +O2 $CFLAGS"
+ if test "$CC" = "$CC_FOR_BUILD"; then
+ #
+ # We're building the build tools with the same
+ # compiler as the one with which we're building
+ # Wireshark, so add the flags to the flags for
+ # that compiler as well.
+ #
+ CFLAGS_FOR_BUILD="-Ae +O2 $CFLAGS"
+ fi
CXXFLAGS="+O2 $CFLAGS"
AC_MSG_RESULT(HP ANSI C compiler - added -Ae +O2)
;;