aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Zawadzki <darkjames-ws@darkjames.pl>2013-12-14 10:43:29 +0000
committerJakub Zawadzki <darkjames-ws@darkjames.pl>2013-12-14 10:43:29 +0000
commit53f438b4ed36a518a7ebac91c018337e5b4c22ed (patch)
tree917cdd3cba4ef11e38f1555051db10a46a04c07d /configure.ac
parent5c79cbf152ac1ee36007060937fb94b5d3b39014 (diff)
Allow -Wmissing-prototypes only for C
It should fix: cc1plus: warning: command line option `-Wmissing-prototypes' is valid for Ada/C/ObjC but not for C++ [enabled by default] (only g++ complains, clang is OK with -Wmissing-prototypes) svn path=/trunk/; revision=54086
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index beecdbfcd7..69884ecc51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -801,7 +801,7 @@ AC_ARG_ENABLE(extra-gcc-checks,
#
# All the registration functions block these for now.
#
- AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wmissing-prototypes)
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wmissing-prototypes, C)
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wmissing-declarations)
#
# A bunch of "that might not work on SPARC" code blocks