aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-04-20 16:49:34 -0700
committerGuy Harris <guy@alum.mit.edu>2014-04-20 23:50:04 +0000
commit4fdd528f897d44b522d7d57ed8718e6c388a47cc (patch)
treee89088d5febb1f754f64bd2d2277d374e01e4771 /configure.ac
parentcbdd5154918269db30a6d938fe15faac05058c7c (diff)
"extra *compiler* warnings", not just "extra warnings".
Rename --enable-extra-warnings to --enable-extra-compiler-warnings, and have the message talking about "extra warnings" talk about "extra compiler warnings", to make it more uniform (the documentation for the --enable flag speaks of "additional compiler warnings") and to clarify that these are warnings from the compiler, not from *shark. Change-Id: Ic1a045670144f8d9eda2e3427142027e2a339156 Reviewed-on: https://code.wireshark.org/review/1230 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index aafd974eff..61dacf8180 100644
--- a/configure.ac
+++ b/configure.ac
@@ -773,8 +773,8 @@ AC_WIRESHARK_CHECK_NON_CXX_WARNING_OPTION_ERROR
# These are not enabled by default, because the warnings they produce
# are very hard or impossible to eliminate.
#
-AC_ARG_ENABLE(extra-warnings,
- AC_HELP_STRING( [--enable-extra-warnings],
+AC_ARG_ENABLE(extra-compiler-warnings,
+ AC_HELP_STRING( [--enable-extra-compiler-warnings],
[do additional compiler warnings @<:@default=no@:>@]),
[
wireshark_extra_flags=$enableval
@@ -1002,7 +1002,7 @@ warnings_as_errors_default="yes"
AC_MSG_CHECKING(whether we should treat compiler warnings as errors)
AC_ARG_ENABLE(warnings-as-errors,
AC_HELP_STRING( [--enable-warnings-as-errors],
- [treat warnings as errors (only for GCC or clang) @<:@default=yes, unless extra warnings are enabled@:>@]),
+ [treat warnings as errors (only for GCC or clang) @<:@default=yes, unless extra compiler warnings are enabled@:>@]),
[
if test "x$ac_supports_gcc_flags" = "xyes" -a "x$enableval" = "xyes"; then
with_warnings_as_errors="yes"