aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-06-18 02:49:57 -0700
committerGuy Harris <guy@alum.mit.edu>2014-06-18 09:50:43 +0000
commit421d817d70737ebd459b7027274bf38bb2d9a2ff (patch)
tree330b713b1db4ccf0bf23ce974bd62440b00ebb9f /configure.ac
parent7939f6888b62b811f62bbb5a22340af92133f846 (diff)
Don't compile anything with -msse4.2 unless the compiler supports it.
This includes ws_mempbrk_sse42.c; if the compiler doesn't support -msse4.2, HAS_SSE4_2 isn't defined, so all the stuff in ws_mempbrk_sse42.c that uses SSE 4.2 will be #ifdeffed out. Not all compilers with which we're built will support -msse4.2; in particular, the ones that aren't compiling for x86 won't.... Change-Id: I69566ca06f602104b40c78b3b06fcb7dfeb054b2 Reviewed-on: https://code.wireshark.org/review/2373 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b0075e8dd0..350cb76924 100644
--- a/configure.ac
+++ b/configure.ac
@@ -981,6 +981,7 @@ then
[
have_sse42=yes
AC_DEFINE(HAVE_SSE4_2, 1, [Support SSSE4.2 (Streaming SIMD Extensions 4.2) instructions])
+ CFLAGS_SSE42="-msse4.2"
AC_MSG_RESULT([yes])
],
[
@@ -996,6 +997,7 @@ else
fi
dnl build libwsutil_sse42 only if there is SSE4.2
AM_CONDITIONAL(SSE42_SUPPORTED, test "x$have_sse42" = "xyes")
+AC_SUBST(CFLAGS_SSE42)
#
# If we're running GCC or clang define _U_ to be "__attribute__((unused))"