aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-06-17 21:58:11 -0700
committerGuy Harris <guy@alum.mit.edu>2014-06-18 04:58:42 +0000
commit20accf341cef4f90997369c6aa26f748e3b9be76 (patch)
tree32ee1d8783c2ae4b3f375173ffeca162c7543fac /configure.ac
parent4cebb0686f85ad3ba6f21558419455b1877c78fa (diff)
Don't do the check for clang/clang++.
Adding -Qunused-arguments to CXXFLAGS causes the checks for -f and -m flags not to fail with clang++, causing the configure script to warn about -f flags supported by clang but not clang++ indicating that the compilers are a mismatched pair. The checks we do for flags should eliminate "unused" -f/-m flags, suppressing the warnings that way. Change-Id: I749d6f499a3d34300518cc0ba539f355377359af Reviewed-on: https://code.wireshark.org/review/2362 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 582640baa7..e032403cb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,7 +58,6 @@ AM_PROG_CC_C_O
AC_PROG_CXX
AC_PROG_CPP
AC_PROG_MKDIR_P
-AC_WIRESHARK_CLANG_CHECK
dnl Work around libtool bug (fixed in the version 1.5a?)
AC_DEFUN([AC_PROVIDE_AC_LIBTOOL_DLOPEN], )