aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-04-20 15:52:34 -0700
committerGuy Harris <guy@alum.mit.edu>2014-04-20 22:53:18 +0000
commit0bdd9a7d7a1a8ce218dc82f22a0a886e0f8bed34 (patch)
tree7bdc5d36211db97c05b531d3a91097bdc14e2141 /configure.ac
parent68f9811b1bed1397d2ba06af63488fe16bc5bb5e (diff)
Rename --enable-extra-compiler-checks to --enable-extra-warnings.
That makes it clearer that what we're enabling are extra warnings, and fits better with the description for --enable-warnings-as-errors, which says the default is "yes, unless extra warnings are enabled". Change-Id: If21f778df0dfdb98acbe02cb6a763ed27f2a7f91 Reviewed-on: https://code.wireshark.org/review/1227 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8cb02dd3bc..aafd974eff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -773,9 +773,9 @@ AC_WIRESHARK_CHECK_NON_CXX_WARNING_OPTION_ERROR
# These are not enabled by default, because the warnings they produce
# are very hard or impossible to eliminate.
#
-AC_ARG_ENABLE(extra-compiler-checks,
- AC_HELP_STRING( [--enable-extra-compiler-checks],
- [do additional -W checks @<:@default=no@:>@]),
+AC_ARG_ENABLE(extra-warnings,
+ AC_HELP_STRING( [--enable-extra-warnings],
+ [do additional compiler warnings @<:@default=no@:>@]),
[
wireshark_extra_flags=$enableval
if test $enableval != no