aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2015-02-04 10:32:02 -0500
committerAnders Broman <a.broman58@gmail.com>2015-02-06 08:11:49 +0000
commit0b0f7fa0911814cb824922b1740a94381ce4d265 (patch)
treef5ca73777789cc78f3ec3b292fa9bf97807ebf5b /configure.ac
parent881ff5df92a1c12a3afaeea3f422cb36f6e84b59 (diff)
More emem removal.
Remove emem's 8-byte-memory-alignment configure check as well as references to all the environment variables emem used. Change-Id: I897aec9e9c68e064454561e7a9f066b18892ec66 Reviewed-on: https://code.wireshark.org/review/6950 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index dad56e06c5..3ca13aebf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2912,28 +2912,6 @@ then
fi
AC_SUBST(extcapdir)
-#
-# Check if (emem) memory allocations must be 8-byte aligned.
-# I haven't been able to write C code that reliably makes that determination
-# (different versions of GCC with or without optimization give different
-# results) so just assume everything except (32-bit) x86 needs 8-byte
-# alignment (64-bit platforms either require 8-byte alignment for pointers
-# and 64-bit integral data types or may get better performance from that;
-# 64-bit x86 will get 8-byte alignment from G_MEM_ALIGN anyway. 32-bit
-# platforms would only require it, or get better performance from it,
-# for 64-bit floating-point values.).
-#
-AC_MSG_CHECKING(whether we need memory allocations to be 8-byte aligned)
-case $host_cpu in
- i386|i486|i586|i686)
- AC_MSG_RESULT(no)
- ;;
- *)
- AC_MSG_RESULT(yes)
- AC_DEFINE(NEED_8_BYTE_ALIGNMENT, 1, [Define if we need memory allocations to be 8-byte aligned])
- ;;
-esac
-
dnl libtool defs
#
# Yes, AM_PROG_LIBTOOL is redundant with newer version(s) of some tool(s)