aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2015-09-14 17:22:47 -0400
committerJeff Morriss <jeff.morriss.ws@gmail.com>2015-09-16 14:43:14 +0000
commit038f3dd28c1f0d5b7f95892e95ab93dbedad10a0 (patch)
tree0683cb38509c94e23ae458567b234d34756753f4 /configure.ac
parent6f84c7b54bccb900c405aad309b2aada72277b61 (diff)
Don't force Lua support in RPMs (some distros don't ship a compatible Lua
anymore). Also make the RPM follow configure's qt4-vs-qt5 choice. Change-Id: I832af99e055d42b92f3a7c8e4378c7a9d5d628b9 Reviewed-on: https://code.wireshark.org/review/10532 Reviewed-by: Jeffrey Smith <whydoubt@gmail.com> Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 401983b5d5..c0632e4c94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3061,10 +3061,19 @@ else
RPMBUILD_WITH_ARGS="--without gtk2 --without gtk3"
fi
if test "x$have_qt" = "xyes" ; then
- RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --with qt"
+ if test "$qt_version" -eq "5"; then
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --with qt5"
+ else
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --with qt"
+ fi
else
RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --without qt"
fi
+if test "x$have_lua" = "xyes" ; then
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --with lua"
+else
+ RPMBUILD_WITH_ARGS="$RPMBUILD_WITH_ARGS --without lua"
+fi
AC_SUBST(RPMBUILD_WITH_ARGS)
dnl Save the cacheable configure results to config.cache before recursing