aboutsummaryrefslogtreecommitdiffstats
path: root/codecs/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-09-09 13:20:33 +0000
committerJörg Mayer <jmayer@loplof.de>2009-09-09 13:20:33 +0000
commitca6b1e2b2142c7727bca82540c14d2a9c41e1a05 (patch)
tree5f35b5d74741be36415415d8d68acdd479e5c606 /codecs/CMakeLists.txt
parenta65f72e8f045ec9c17848c6508c9ccd27e2e91f4 (diff)
CMAKE: Get most of of missing *build* pieces into place
svn path=/trunk/; revision=29819
Diffstat (limited to 'codecs/CMakeLists.txt')
-rw-r--r--codecs/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/codecs/CMakeLists.txt b/codecs/CMakeLists.txt
new file mode 100644
index 0000000000..99b3f966a9
--- /dev/null
+++ b/codecs/CMakeLists.txt
@@ -0,0 +1,32 @@
+# CMakeLists.txt
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+set(CODECS_FILES
+ G711a/G711adecode.c
+ G711u/G711udecode.c
+)
+
+add_library(codecs STATIC
+ ${CODECS_FILES}
+)
+