aboutsummaryrefslogtreecommitdiffstats
path: root/codecs/CMakeLists.txt
diff options
context:
space:
mode:
authorPascal Quantin <pascal.quantin@gmail.com>2017-07-26 23:23:12 +0200
committerAnders Broman <a.broman58@gmail.com>2017-07-30 05:22:35 +0000
commit3e54cabf8193e6a8cd607b1671defb8b6800b53d (patch)
tree63297098c0c26c1c875ab0959d9679d70b3c6e65 /codecs/CMakeLists.txt
parent32b446d5a8f146565b81324d1a18bcb053e07c5f (diff)
Add G.729 decoding based on bcg729 library
Bug: 13635 Change-Id: Ic22a0719a59da13e51425aeb747e88caca0d6512 Reviewed-on: https://code.wireshark.org/review/22808 Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Reviewed-by: Pascal Quantin <pascal.quantin@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'codecs/CMakeLists.txt')
-rw-r--r--codecs/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/codecs/CMakeLists.txt b/codecs/CMakeLists.txt
index 4595054059..9c47ff69d0 100644
--- a/codecs/CMakeLists.txt
+++ b/codecs/CMakeLists.txt
@@ -52,6 +52,11 @@ if(HAVE_SPANDSP)
list(APPEND wscodecs_LIBS ${SPANDSP_LIBRARIES})
endif()
+if(HAVE_BCG729)
+ list(APPEND WSCODECS_FILES G729/G729decode.c)
+ list(APPEND wscodecs_LIBS ${BCG729_LIBRARIES})
+endif()
+
add_library(wscodecs ${LINK_MODE_LIB}
${WSCODECS_FILES}
${CMAKE_BINARY_DIR}/image/libwscodecs.rc