aboutsummaryrefslogtreecommitdiffstats
path: root/codecs/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-12-12 16:51:40 -0800
committerGerald Combs <gerald@wireshark.org>2015-10-02 18:26:05 +0000
commit3687d393040a40655d84e3e03417a474032bad86 (patch)
tree55f208b60abb59c5812bae2407a9b36dfdd2f09a /codecs/CMakeLists.txt
parentfd5eafa50a77bc319a240727600be38307e54f86 (diff)
Qt: Initial RTP playback.
Note the "initial". This is woefully incomplete. See the "to do" lists below and in the code. This differs a bit from the GTK+ version in that you specify one or more streams to be decoded. Instead of showing waveforms in individual widgets, add them all to a single QCustomPlot. This conserves screen real estate and lets us more easily take advantage of the QCP API. It also looks better IMHO. Change a bunch of checks for QtMultimediaWidgets to QtMultimedia. We probably won't use the widgets until we make 5.0 our minimum Qt version and plain old QtMultimedia lets us support Qt 4 more easily (in theory at least). Add resampling code from libspeex. I initially used this to resample each packet to match the preferred rate of our output device, but this resulted in poorer audio quality than expected. Leave it in and use to create visual samples for QCP and to match rates any time the rate changes. The latter is currently untested. Add some debugging macros. Note that both the RTP player and RTP analysis dialogs decode audio data using different code. Note that voip_calls_packet and voip_calls_init_tap appear to be dead code. To do: - Add silence frames where needed. - Implement the jitter buffer. - Implement the playback timing controls. - Tapping / scanning streams might be too slow. Change-Id: I20dd3b66d3df53c9b1f3501262dc01458849f6b4 Bug: 9007 Reviewed-on: https://code.wireshark.org/review/10458 Petri-Dish: Gerald Combs <gerald@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'codecs/CMakeLists.txt')
-rw-r--r--codecs/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/codecs/CMakeLists.txt b/codecs/CMakeLists.txt
index 6397db18c0..63ac64d08d 100644
--- a/codecs/CMakeLists.txt
+++ b/codecs/CMakeLists.txt
@@ -27,6 +27,17 @@ set(CODECS_FILES
# handle or define.
# G722/G722decode.c
# G726/G726decode.c
+ speex/resample.c
+)
+
+# Enables visibility in IDEs
+file(GLOB EXTRA_CODEC_HEADERS
+ codecs.h
+ G711a/G711adecode.h G711a/G711atable.h
+ G711u/G711udecode.h G711u/G711utable.h
+ speex/arch.h
+ speex/speex_resampler.h
+ speex/stack_alloc.h
)
if(SBC_FOUND)