aboutsummaryrefslogtreecommitdiffstats
path: root/codecs/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Willmann <dwillmann@sysmocom.de>2016-07-12 20:25:33 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-05-15 21:28:50 +0200
commit77e92cb5dce9b9f5f2689c3ca58705f67edad616 (patch)
tree0be3bc072531e8166630c2098bf49abfe421d849 /codecs/CMakeLists.txt
parent66a26f25698878caa0556127d09a5bdce73c76d7 (diff)
Add AMR codec supportosmocom/master
CMake work and rebase on current wireshark master by Pau Espin Pedrol. Change-Id: I5ec963b910f8f271aa2e5d680ea33e2170a6f367
Diffstat (limited to 'codecs/CMakeLists.txt')
-rw-r--r--codecs/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/codecs/CMakeLists.txt b/codecs/CMakeLists.txt
index 2f446f6648..ce6ca048fb 100644
--- a/codecs/CMakeLists.txt
+++ b/codecs/CMakeLists.txt
@@ -49,6 +49,11 @@ if(HAVE_BCG729)
list(APPEND wscodecs_LIBS ${BCG729_LIBRARIES})
endif()
+if(AMRNB_FOUND)
+ list(APPEND WSCODECS_FILES amr/amrdecode.c)
+ list(APPEND wscodecs_LIBS ${AMRNB_LIBRARIES})
+endif()
+
add_library(wscodecs
${WSCODECS_FILES}
${CMAKE_BINARY_DIR}/image/libwscodecs.rc