aboutsummaryrefslogtreecommitdiffstats
path: root/caputils/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-07-04 00:24:02 -0700
committerGuy Harris <guy@alum.mit.edu>2014-07-04 07:25:26 +0000
commit9e6487f24751d1c1a047ee82e158077ac67c9c68 (patch)
tree3cc4a8524062948f4951914dc9af489e0d7c4572 /caputils/CMakeLists.txt
parentc5643a3d257909ed3e8752cd729b9192ae719683 (diff)
Move utility routines for capturing into a libcaputils static library.
Some of those routines are used only in dumpcap; others are used in TShark and Wireshark as well. Change-Id: I9d92483f2fcff57a7d8b6bf6bdf2870505d19fb7 Reviewed-on: https://code.wireshark.org/review/2841 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'caputils/CMakeLists.txt')
-rw-r--r--caputils/CMakeLists.txt61
1 files changed, 61 insertions, 0 deletions
diff --git a/caputils/CMakeLists.txt b/caputils/CMakeLists.txt
new file mode 100644
index 0000000000..4c8dab086a
--- /dev/null
+++ b/caputils/CMakeLists.txt
@@ -0,0 +1,61 @@
+# CMakeLists.txt
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+#
+
+
+if(UNIX)
+ set(PLATFORM_CAPUTILS_SRC
+ capture-pcap-util-unix.c
+ )
+endif()
+
+if(WIN32)
+ set(PLATFORM_CAPUTILS_SRC
+ capture_win_ifnames.c
+ capture-wpcap.c
+ capture_wpcap_packet.c
+ )
+endif()
+
+set(CAPUTILS_SRC
+ ${PLATFORM_CAPUTILS_SRC}
+ capture-pcap-util.c
+ ws80211_utils.c
+)
+
+set(CLEAN_FILES
+ ${CAPUTILS_SRC}
+)
+
+if (WERROR)
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS -Werror
+ )
+endif()
+
+
+add_library(caputils STATIC
+ ${CAPUTILS_SRC}
+)
+
+set_target_properties(caputils PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
+set_target_properties(caputils PROPERTIES FOLDER "CAPUTILS")