aboutsummaryrefslogtreecommitdiffstats
path: root/capchild/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2019-05-01 19:02:34 +0100
committerJoão Valverde <j@v6e.pt>2019-05-03 21:57:05 +0000
commitc7d86568a07845d56508baa88ece7853ce193eae (patch)
tree479090a83edd0b8e98980e6195e4350a702efe0f /capchild/CMakeLists.txt
parent4c5d2f5ccf822c07746853b065322c34dc322e8a (diff)
CMake: Remove wsutil pcap dependency
Change-Id: Ic5a3653cb8bcc33e0be108c8b201567e7090f9f5 Reviewed-on: https://code.wireshark.org/review/33043 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'capchild/CMakeLists.txt')
-rw-r--r--capchild/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/capchild/CMakeLists.txt b/capchild/CMakeLists.txt
index cfea58eb99..688cdbcbc9 100644
--- a/capchild/CMakeLists.txt
+++ b/capchild/CMakeLists.txt
@@ -26,7 +26,11 @@ add_library(capchild STATIC
${CAPCHILD_SRC}
)
-target_link_libraries(capchild PRIVATE wsutil)
+target_link_libraries(capchild
+ PRIVATE
+ wsutil
+ $<$<BOOL:${PCAP_FOUND}>:pcap::pcap>
+)
set_target_properties(capchild PROPERTIES
LINK_FLAGS "${WS_LINK_FLAGS}"