aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Fisher <sfisher@sdf.org>2014-11-25 14:44:03 -0700
committerStephen Fisher <sfisher@sdf.org>2014-11-25 22:39:00 +0000
commite2ef6c4cfc3c07b2fb1fce80e1b3d614aa7ad670 (patch)
treec1546627c254dbaab37ed309a53c419220a124af /Makefile.am
parente2132f9b152a5ba59ddf484b144c71c7d2447206 (diff)
Add on to the dummy.cpp hack that forces wireshark to be linked with a
c++ compiler to automatically create a dummy.cpp file and remove it when make clean is issued. This allows make tags to work again since the file isn't missing. Change-Id: I17191ad2acc281734fa12da4d347fd3116018f67 Reviewed-on: https://code.wireshark.org/review/5494 Petri-Dish: Stephen Fisher <sfisher@sdf.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Stephen Fisher <sfisher@sdf.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 211168c886..df97d1fbaa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -452,6 +452,11 @@ endif
nodist_EXTRA_wireshark_cxx_SOURCES = dummy.cpp
wireshark_cxx_SOURCES =
+dummy.cpp:
+ echo 'static void dummy();' > $@
+# Generate the dummy.cpp for above so that "make tags" will still work.
+# ("make clean" will remove it.)
+
if ENABLE_STATIC
tshark_LDFLAGS = -Wl,-static -all-static
else
@@ -691,6 +696,7 @@ services:
CLEANFILES = \
*~ \
doxygen-core.tag \
+ dummy.cpp \
vgcore.*
#