aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2015-11-19 11:30:44 +0100
committerAnders Broman <a.broman58@gmail.com>2015-11-19 15:29:18 +0000
commitd6da95231ee790fd884ca2a41fe59aa9b05ccde9 (patch)
tree521b455286bad8276f270cb69fd4bb53192643dd /Makefile.am
parent1a841483e9df85f913ece0286a6e0d4f97a859c2 (diff)
extcap: add sshdump.
sshdump is an extcap module that allows dumping from a remote host using an ssh connection. It goes with the existing extcap plugin interface. Change-Id: I8987614fdd817b8173a50130812bc643a4833bca Reviewed-on: https://code.wireshark.org/review/11402 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e3a12dbce5..ebce8cc270 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,11 +43,12 @@ bin_PROGRAMS = \
@reordercap_bin@ \
@rawshark_bin@ \
@androiddump_bin@ \
+ @sshdump_bin@ \
@echld_test_bin@
EXTRA_PROGRAMS = wireshark-gtk wireshark tshark tfshark capinfos captype editcap \
mergecap dftest randpkt text2pcap dumpcap reordercap rawshark androiddump \
- echld_test
+ sshdump echld_test
#
# Wireshark configuration files are put in $(pkgdatadir).
@@ -547,6 +548,23 @@ androiddump_LDADD = \
androiddump_CFLAGS = $(AM_CLEAN_CFLAGS)
+if ENABLE_STATIC
+ sshdump_LDFLAGS = -Wl,-static -all-static
+else
+ sshdump_LDFLAGS = -export-dynamic
+endif
+
+# Libraries and plugin flags with which to link sshdump.
+sshdump_LDADD = \
+ wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
+ @GLIB_LIBS@ \
+ @LIBSSH_LIBS@ \
+ @SOCKET_LIBS@
+
+sshdump_CFLAGS = $(AM_CLEAN_CFLAGS)
+
+
# Libraries with which to link text2pcap.
text2pcap_LDADD = \
wsutil/libwsutil.la \
@@ -1322,6 +1340,7 @@ EXTRA_DIST = \
cmake/modules/FindSETCAP.cmake \
cmake/modules/FindSH.cmake \
cmake/modules/FindSMI.cmake \
+ cmake/modules/FindLIBSSH.cmake \
cmake/modules/FindWinSparkle.cmake \
cmake/modules/FindWireshark.cmake \
cmake/modules/FindWSWinLibs.cmake \