aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-10-23 08:41:39 -0700
committerGerald Combs <gerald@wireshark.org>2014-10-23 15:52:53 +0000
commitd2bb61a3a9ff29826aa332b7e4ee484f3a4746d9 (patch)
tree0f84a993eda44196d9ba2df4f48cdb0c0d9898a2 /Makefile.am
parent97a920cb21c0617f78a03c33510594e9904fd052 (diff)
OS X: Integrate CMake and osx-app.sh
Add a -cb/--create-bundle option to osx-app.sh which builds the application bundle. Use it in Autotools. (CMake does this by default.) Copy over linker flags from configure.ac to CMakeLists.txt to support rpathification and code signing. Add an osx-app custom target to CMake. Change-Id: I6c20a1c27f8954aaea62904b7425b9312d994803 Reviewed-on: https://code.wireshark.org/review/4918 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e81c68232..0fc8f95cff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1346,7 +1346,9 @@ osx-app: $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA) packaging/macosx/Info.plist
rm -rf $(stagedir) ; \
$(MAKE) DESTDIR=$(stagedir) install; \
cd $(srcdir)/packaging/macosx ; \
- ./osx-app.sh @OSX_APP_FLAGS@ -bp ../staging/$(PACKAGE).inst$(bindir) ; \
+ ./osx-app.sh @OSX_APP_FLAGS@ \
+ --create-bundle \
+ --binary-path ../staging/$(PACKAGE).inst$(bindir) ; \
else \
echo "Error: OS X packaging tools not found." ; \
echo "Package build abandoned." ; \