aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorOlivier Biot <obiot.ethereal@gmail.com>2004-07-28 20:51:29 +0000
committerOlivier Biot <obiot.ethereal@gmail.com>2004-07-28 20:51:29 +0000
commitcb6b29786bb98412602a039658e5c5b134595b0e (patch)
tree4b7470a6fe9495e34bcbc24617570918edc5edeb /Makefile.am
parent1f7a02524671165a276463acb4e84e8f6e3a2442 (diff)
From Ian Schorr: capinfo - provides capture file information.
svn path=/trunk/; revision=11555
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 37d06b3035..87ecdba9a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,13 +60,14 @@ ACLOCAL_AMFLAGS = `./aclocal-flags`
# automake will arrange that the Makefile define it as the union of all
# the "man{section}_MANS" variables.
#
-bin_PROGRAMS = @ethereal_bin@ @editcap_bin@ @mergecap_bin@ @tethereal_bin@ @dftest_bin@ @randpkt_bin@ @text2pcap_bin@
+bin_PROGRAMS = @ethereal_bin@ @capinfo_bin@ @editcap_bin@ @mergecap_bin@ @tethereal_bin@ @dftest_bin@ @randpkt_bin@ @text2pcap_bin@
bin_SCRIPTS = @idl2eth_bin@
-man1_MANS = @ethereal_man@ @editcap_man@ @mergecap_man@ @tethereal_man@ @text2pcap_man@ @idl2eth_man@
+man1_MANS = @ethereal_man@ @capinfo_man@ @editcap_man@ @mergecap_man@ @tethereal_man@ @text2pcap_man@ @idl2eth_man@
man4_MANS = @etherealfilter_man@
man_MANS =
-EXTRA_PROGRAMS = ethereal tethereal editcap mergecap dftest randpkt text2pcap
+EXTRA_PROGRAMS = ethereal tethereal capinfo editcap mergecap dftest \
+ randpkt text2pcap
EXTRA_SCRIPTS = idl2eth
#
@@ -74,8 +75,8 @@ EXTRA_SCRIPTS = idl2eth
# contains the "AUTHORS-SHORT" and "manuf" files and a "diameter" directory.
#
pkgdata_DATA = AUTHORS-SHORT manuf ethereal.html tethereal.html \
- ethereal-filter.html editcap.html idl2eth.html mergecap.html \
- text2pcap.html
+ ethereal-filter.html capinfo.html editcap.html \
+ idl2eth.html mergecap.html text2pcap.html
#
# Install the Diameter DTD and XML files in the "diameter" subdirectory
@@ -276,9 +277,11 @@ text2pcap_LDADD = $(text2pcap_optional_objects) \
mergecap_DEPENDENCIES = wiretap/libwiretap.la
# This is the automake dependency variable for the executable
+capinfo_DEPENDENCIES = wiretap/libwiretap.la
editcap_DEPENDENCIES = wiretap/libwiretap.la
# This automake variable adds to the link-line for the executable
+capinfo_LDADD = wiretap/libwiretap.la @GLIB_LIBS@
editcap_LDADD = wiretap/libwiretap.la @GLIB_LIBS@
mergecap_LDADD = wiretap/libwiretap.la @GLIB_LIBS@
@@ -401,6 +404,7 @@ EXTRA_DIST = \
aclocal-fallback/gtk.m4 \
aclocal-flags \
autogen.sh \
+ capinfo.c \
capture-wpcap.c \
capture-wpcap.h \
cleanbld.bat \
@@ -429,6 +433,7 @@ EXTRA_DIST = \
doc/README.tapping \
doc/README.tvbuff \
doc/README.xml-output \
+ doc/capinfo.pod \
doc/dfilter2pod.pl \
doc/editcap.pod \
doc/ethereal-filter.pod.template \
@@ -559,6 +564,10 @@ ethereal-filter.4: tethereal doc/ethereal-filter.pod.template
(cd doc ; \
$(MAKE) ../ethereal-filter.4 )
+capinfo.1: doc/capinfo.pod
+ (cd doc ; \
+ $(MAKE) ../capinfo.1 )
+
editcap.1: doc/editcap.pod
(cd doc ; \
$(MAKE) ../editcap.1 )
@@ -587,6 +596,10 @@ ethereal-filter.html: tethereal doc/ethereal-filter.pod.template
(cd doc ; \
$(MAKE) ../ethereal-filter.html )
+capinfo.html: doc/capinfo.pod
+ (cd doc ; \
+ $(MAKE) ../capinfo.html )
+
editcap.html: doc/editcap.pod
(cd doc ; \
$(MAKE) ../editcap.html )