aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2001-11-24 08:14:12 +0000
committerGuy Harris <guy@alum.mit.edu>2001-11-24 08:14:12 +0000
commitc871a24514acf5552b816d40845cc11bb40ca9a7 (patch)
tree193e3364fe4bea8d3b55fd2076058851c2fbd7b2 /Makefile.am
parent73fc903278dc638f562774b4f0607a2071a66eeb (diff)
Support for time stamping packets in text2pcap, from Gordon McKinney.
svn path=/trunk/; revision=4252
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e742a9978..258a636350 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.383 2001/11/22 03:07:05 hagbard Exp $
+# $Id: Makefile.am,v 1.384 2001/11/24 08:14:10 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@ethereal.com>
@@ -640,9 +640,16 @@ tethereal_static_LDADD = \
tethereal_LDFLAGS = -export-dynamic
tethereal_static_LDFLAGS = -Wl,-static
+# Optional objects that I know how to build, and that are needed by
+# text2pcap.
+text2pcap_optional_objects = @STRERROR_O@ @STRPTIME_O@
+
text2pcap_SOURCES = text2pcap.c text2pcap-scanner.l
text2pcap_DEPENDENCIES = text2pcap.h
+# This automake variable adds to the link-line for the executable
+text2pcap_LDADD = $(text2pcap_optional_objects)
+
mergecap_SOURCES = mergecap.c
mergecap_DEPENDENCIES = wiretap/libwiretap.a