aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-12-04 00:03:03 -0800
committerGuy Harris <guy@alum.mit.edu>2014-12-04 08:03:32 +0000
commitb8a23643b339037e13e61baa22ce86fba7c96869 (patch)
treea56a07d4bfbcf1d8685c123dcba31ff6a086ba07 /Makefile.am
parentc02417f851c951ce31b54c4d85934250a9c9df64 (diff)
Don't do the desktop integration stuff if we're not building Wireshark.
Wireshark is the desktop app; if we're not building it (i.e., we're only building the command-line TShark), we don't need any desktop files. Change-Id: Id8244b417fd53c9d55b4d77fe3ad748c98868ad7 Reviewed-on: https://code.wireshark.org/review/5615 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7157167a63..22ca89e3fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1423,9 +1423,11 @@ patch-bzip2: distdir
# FreeBSD install command has a -T flag that takes an argument and
# that has completely different semantics.
#
-# We neither need nor want any of this on OS X.
+# We neither need nor want any of this on OS X, nor do we want it if
+# we're not building Wireshark (that being the only desktop app).
#
install-data-local:
+if BUILDING_WIRESHARK
if NOT_OS_X
mkdir -p $(DESTDIR)$(datadir)/mime/packages
install -m 644 $(srcdir)/wireshark-mime-package.xml $(DESTDIR)$(datadir)/mime/packages/wireshark.xml
@@ -1445,8 +1447,10 @@ if NOT_OS_X
mkdir -p $(DESTDIR)$(datadir)/icons/hicolor/scalable/apps
install -m 644 $(srcdir)/image/wsicon.svg $(DESTDIR)$(datadir)/icons/hicolor/scalable/apps/wireshark.svg
endif
+endif
uninstall-local:
+if BUILDING_WIRESHARK
if NOT_OS_X
rm -f $(DESTDIR)$(datadir)/mime/packages/wireshark.xml
rm -f $(DESTDIR)$(datadir)/applications/wireshark.desktop
@@ -1457,6 +1461,7 @@ if NOT_OS_X
done
rm -f $(DESTDIR)$(datadir)/icons/hicolor/scalable/apps/wireshark.svg
endif
+endif
install-data-hook: update-databases-and-caches-install
uninstall-hook: update-databases-and-caches-uninstall
@@ -1487,25 +1492,32 @@ uninstall-hook: update-databases-and-caches-uninstall
#
# The update-alternatives suggestions need work.
#
-# We neither need nor want any of this on OS X.
+# We neither need nor want any of this on OS X, nor do we want it if
+# we're not building Wireshark (that being the only desktop app).
#
update-databases-and-caches-common:
+if BUILDING_WIRESHARK
if NOT_OS_X
@echo "You may need to run \"ldconfig\" as root"
@echo "You may need to run \"update-desktop-database $(datadir)/applications\""
@echo "You may need to run \"update-mime-database $(datadir)/mime\""
@echo "You may need to run \"gtk-update-icon-cache -f -t $(datadir)/icons/hicolor\""
endif
+endif
update-databases-and-caches-install: update-databases-and-caches-common
+if BUILDING_WIRESHARK
if NOT_OS_X
@echo "You may need to run \"update-alternatives --install $(bindir)/wireshark wireshark $(bindir)/wireshark-qt 50\""
endif
+endif
update-databases-and-caches-uninstall: update-databases-and-caches-common
+if BUILDING_WIRESHARK
if NOT_OS_X
@echo "You may need to run \"update-alternatives --remove wireshark $(bindir)/wireshark-qt\""
endif
+endif
# Used by svr4-package and osx-package
# We load top_stagedir with an absolute path so that libtool doesn't freak.