aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBalint Reczey <balint@balintreczey.hu>2015-11-08 22:38:50 +0400
committerBalint Reczey <balint@balintreczey.hu>2015-11-11 04:45:48 +0000
commitb732f44d1e5e1c0ba5b863ddda69b04edab367a6 (patch)
tree9bd2e90032033186628f7ebefcb7e5f9bb83373c /Makefile.am
parent7d86cc9194757afae54b216620d61a6eabb04e74 (diff)
GTK: Add separate working desktop file for GTK+ Wireshark GUI
Change-Id: I52a749b7e2b9a4a5cb2968409e140b9d5f2002f6 Reviewed-on: https://code.wireshark.org/review/11696 Reviewed-by: Balint Reczey <balint@balintreczey.hu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 665e37e621..57fe846223 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1269,6 +1269,7 @@ EXTRA_DIST = \
text2pcap.h \
services \
wireshark.desktop \
+ wireshark-gtk.desktop \
wireshark-mime-package.xml \
wireshark.appdata.xml \
wireshark.pc.in \
@@ -1496,9 +1497,9 @@ if NOT_OS_X
install -m 644 $(srcdir)/wireshark.appdata.xml $(DESTDIR)$(datadir)/appdata/wireshark.appdata.xml
mkdir -p $(DESTDIR)$(datadir)/applications
if test x$(DESKTOP_FILE_INSTALL) != x ; then \
- $(DESKTOP_FILE_INSTALL) --dir $(DESTDIR)$(datadir)/applications $(srcdir)/wireshark.desktop; \
+ $(DESKTOP_FILE_INSTALL) --dir $(DESTDIR)$(datadir)/applications $(srcdir)/wireshark.desktop $(srcdir)/wireshark-gtk.desktop ; \
else \
- install -m 644 $(srcdir)/wireshark.desktop $(DESTDIR)$(datadir)/applications/wireshark.desktop; \
+ install -m 644 $(srcdir)/wireshark.desktop $(DESTDIR)$(datadir)/applications/wireshark.desktop $(DESTDIR)$(datadir)/applications/wireshark-gtk.desktop; \
fi
for size in 16 24 32 48 64 128 256; \
do \
@@ -1517,6 +1518,7 @@ if BUILDING_WIRESHARK
if NOT_OS_X
rm -f $(DESTDIR)$(datadir)/appdata/wireshark.appdata.xml
rm -f $(DESTDIR)$(datadir)/applications/wireshark.desktop
+ rm -f $(DESTDIR)$(datadir)/applications/wireshark-gtk.desktop
rm -f $(DESTDIR)$(datadir)/mime/packages/wireshark.xml
for size in 16 24 32 48 64 128 256; \
do \