aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-14 11:55:29 +0100
committerJoão Valverde <j@v6e.pt>2017-10-15 05:20:59 +0000
commitb5948a042a9925619a464cde7b0de245fab45594 (patch)
tree64ba28d39baa851c0b39dd1b71dae84fe074153e /Makefile.am
parent5842fe4afe9b5feeeef8cd78a82fa32bcefc1a39 (diff)
autotools: dispense with desktop-file-install
Change-Id: I20717e669709bde6c7b1ff7d10f928e2ec2cc263 Reviewed-on: https://code.wireshark.org/review/23909 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7822edb08e..f37f69337c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -984,11 +984,7 @@ if NOT_MACOS
mkdir -p $(DESTDIR)$(datadir)/appdata
install -m 644 $(srcdir)/wireshark.appdata.xml $(DESTDIR)$(datadir)/appdata/wireshark.appdata.xml
mkdir -p $(DESTDIR)$(datadir)/applications
- if test x$(DESKTOP_FILE_INSTALL) != x ; then \
- $(DESKTOP_FILE_INSTALL) --dir $(DESTDIR)$(datadir)/applications $(srcdir)/wireshark.desktop $(srcdir)/wireshark-gtk.desktop ; \
- else \
- install -m 644 $(srcdir)/wireshark.desktop $(srcdir)/wireshark-gtk.desktop $(DESTDIR)$(datadir)/applications; \
- fi
+ install -m 644 $(srcdir)/wireshark.desktop $(srcdir)/wireshark-gtk.desktop $(DESTDIR)$(datadir)/applications
for size in 16 24 32 48 64 128 256; \
do \
mkdir -p $(DESTDIR)$(datadir)/icons/hicolor/$${size}x$${size}/apps ; \