aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-10-14 15:29:04 -0700
committerGerald Combs <gerald@wireshark.org>2015-10-16 03:52:42 +0000
commitb4a4de78d8f78f0cea54b9ae846a120c2a68d893 (patch)
treee0d7c75cb1a94e4dd625738d61b324e9f8301b83 /Makefile.am
parentb84b0315d3e917b7ab294f36cfc7a24e9c2d3cd0 (diff)
Use buttons to display the main status bar icons.
Use QToolButtons to display the expert indicator and comment icons in the main status bar. Use the same style sheet hack we use in ProgressFrame to un-style the buttons. Make sure we specify the @2x comment icon in our .qrc file so that it's loaded and used on retina displays. Move the comment and expert .pngs to the stock icon directory and use StockIcon to load them. Remove status.qrc since it's no longer used. Change-Id: I84485b22656f8f9af29ad3c02446ffefb6657ed5 Reviewed-on: https://code.wireshark.org/review/11048 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 14 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index b8e0161188..4a1d70fe20 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -893,23 +893,11 @@ EXTRA_DIST = \
image/capture_comment_disabled.png \
image/capture_comment_update.png \
image/capture_comment_update.svg \
- image/capture_comment_update@2x.png \
image/clist_ascend.xpm \
image/clist_descend.xpm \
image/copy-8.png \
image/dumpcap.rc.in \
image/editcap.rc.in \
- image/expert_chat.png \
- image/expert_chat@2x.png \
- image/expert_error.png \
- image/expert_error@2x.png \
- image/expert_indicators.svg \
- image/expert_none.png \
- image/expert_none@2x.png \
- image/expert_note.png \
- image/expert_note@2x.png \
- image/expert_warn.png \
- image/expert_warn@2x.png \
image/file_dlg_win32.rc \
image/hi16-app-wireshark.png \
image/hi32-app-wireshark.png \
@@ -949,7 +937,6 @@ EXTRA_DIST = \
image/README.image \
image/reordercap.rc.in \
image/rubberband-16.png \
- image/status.qrc \
image/stock_dialog_error_48.xpm \
image/stock_dialog_info_48.xpm \
image/stock_dialog_question_48.xpm \
@@ -957,6 +944,20 @@ EXTRA_DIST = \
image/stock_dialog_warning_48.xpm \
image/text2pcap.rc.in \
image/tfshark.rc.in \
+ image/toolbar/14x14/x-capture-comment-update.png \
+ image/toolbar/14x14/x-capture-comment-update.svg \
+ image/toolbar/14x14/x-capture-comment-update@2x.png \
+ image/toolbar/14x14/x-expert-chat.png \
+ image/toolbar/14x14/x-expert-chat@2x.png \
+ image/toolbar/14x14/x-expert-error.png \
+ image/toolbar/14x14/x-expert-error@2x.png \
+ image/toolbar/14x14/x-expert-indicators.svg \
+ image/toolbar/14x14/x-expert-none.png \
+ image/toolbar/14x14/x-expert-none@2x.png \
+ image/toolbar/14x14/x-expert-note.png \
+ image/toolbar/14x14/x-expert-note@2x.png \
+ image/toolbar/14x14/x-expert-warn.png \
+ image/toolbar/14x14/x-expert-warn@2x.png \
image/toolbar/14x14/x-filter-bookmark.active.png \
image/toolbar/14x14/x-filter-bookmark.active.svg \
image/toolbar/14x14/x-filter-bookmark.active@2x.png \