aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2016-02-18 04:06:13 -0800
committerGuy Harris <guy@alum.mit.edu>2016-02-18 12:55:26 +0000
commitb32a5ee98cd4c0e17b900c77b046f7977cbd12bb (patch)
tree570a94b1eac6a16e37d71e97209337e1e9dbe3aa /Makefile.am
parent7b6e5264391521d1519d16ff148a7a62c370e5fd (diff)
Don't add the wiretap directory to the list of include directories.
If you include something from the wiretap directory, always precede it with wiretap/. Fix some includes of files in the top-level directory to use a path relative to the current directory, not relative to the wiretap directory. This makes it a bit clearer what's being included. Change-Id: Ib99655a13c6006cf6c3112e9d4db6f47df9aff54 Reviewed-on: https://code.wireshark.org/review/13990 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1976a2bfd2..140f95bfb2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,9 +27,8 @@ AM_DISTCHECK_CONFIGURE_FLAGS=@GUI_CONFIGURE_FLAGS@
ACLOCAL_AMFLAGS = `./aclocal-flags`
# Common headers
-AM_CPPFLAGS += -I$(top_srcdir)/wiretap $(LIBGNUTLS_CFLAGS) \
- $(LIBGCRYPT_CFLAGS) $(LIBSMI_CFLAGS) $(LUA_CFLAGS) \
- $(KRB5_CFLAGS)
+AM_CPPFLAGS += $(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS) $(LIBSMI_CFLAGS) \
+ $(LUA_CFLAGS) $(KRB5_CFLAGS)
bin_PROGRAMS = \
@wireshark_bin@ \