aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-15 11:25:17 +0100
committerJoão Valverde <j@v6e.pt>2017-10-15 10:34:50 +0000
commit9ac61baa862e4008ef8fd5326c9d8602f52f8ae9 (patch)
treeefcb82c0cd24200df55df6b4943c5c426af9f37c /Makefile.am
parentf053b082cde9e6fdc8e2bf789ca80bcad779b136 (diff)
autotools: Make some installation hints more visible
Change-Id: I347f2983f5d8f11791d0ed0e51ba51de36b1d11f Reviewed-on: https://code.wireshark.org/review/23925 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 6 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index f37f69337c..dc616272b6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1017,27 +1017,12 @@ install-data-hook: update-databases-and-caches-install
uninstall-hook: update-databases-and-caches-uninstall
#
-# XXX - which of this stuff can, and should, we do ourselves?
+# ldconfig may be needed to update a shared library. libtool warns about this.
#
-# If we're "installing" under $(DESTDIR) as part of the process of
-# building a package, we probably don't need to, and shouldn't, do
-# any of this.
+# update-desktop-database and update-mime-database may be needed on
+# freedesktop.org desktops.
#
-# If we're installing for use, we may need to do some of this; which
-# of them do we need to tell where to search, especially if we're
-# installing somewhere other than under /usr or /usr/local?
-#
-# What if we're installing in the user's home directory?
-#
-# What if we're installing under /opt?
-#
-# We only need to run ldconfig on systems where it's necessary in order
-# to update a shared library cache to know about our shared libraries.
-#
-# We only need to run update-desktop-database and update-mime-database
-# on freedesktop.org desktops.
-#
-# We only need to run gtk-update-icon-cache if we're installing a GTK+
+# gtk-update-icon-cache may be needed only if we're installing a GTK+
# version of Wireshark.
#
# We neither need nor want any of this on macOS, nor do we want it if
@@ -1046,10 +1031,12 @@ uninstall-hook: update-databases-and-caches-uninstall
update-databases-and-caches-common:
if BUILDING_WIRESHARK
if NOT_MACOS
+ @echo "-------------------------------------------------------------------------------"
@echo "You may need to run \"ldconfig\" as root"
@echo "You may need to run \"update-desktop-database $(datadir)/applications\""
@echo "You may need to run \"update-mime-database $(datadir)/mime\""
@echo "You may need to run \"gtk-update-icon-cache -f -t $(datadir)/icons/hicolor\""
+ @echo "-------------------------------------------------------------------------------"
endif
endif